Project

General

Profile

Bug #8807

More recent glib updates break hald build

Added by Dan McDonald over 3 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Start date:
2017-11-16
Due date:
% Done:

100%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage
Gerrit CR:

Description

Starting with OmniOS{,ce} r151024, the gate won't build without errors such as these:

{pre}
WARNING: The token "BOOL" is deprecated; use "BOOLEAN" instead
WARNING: The token "BOOL" is deprecated; use "BOOLEAN" instead
WARNING: The token "BOOL" is deprecated; use "BOOLEAN" instead
WARNING: The token "BOOL" is deprecated; use "BOOLEAN" instead
WARNING: The token "BOOL" is deprecated; use "BOOLEAN" instead
WARNING: The token "BOOL" is deprecated; use "BOOLEAN" instead
WARNING: The token "BOOL" is deprecated; use "BOOLEAN" instead
WARNING: The token "BOOL" is deprecated; use "BOOLEAN" instead
WARNING: The token "BOOL" is deprecated; use "BOOLEAN" instead
WARNING: The token "BOOL" is deprecated; use "BOOLEAN" instead {pre}

OmniOS's child fixes this. We need this upstream so -gate can build on modern OmniOS.

Also available in: Atom PDF