Project

General

Profile

Bug #8846

mpi: right-hand operand of comma expression has no effect

Added by Toomas Soome over 3 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
driver - device drivers
Start date:
2017-11-21
Due date:
% Done:

90%

Estimated time:
Difficulty:
Medium
Tags:
Gerrit CR:

Description

Debug build error from gcc 6:

    In file included from /code/illumos-gate/usr/src/common/mpi/mpi.c:52:0:
    /code/illumos-gate/usr/src/common/mpi/mpi.c: In function 's_mp_fixup_reciprocal':
    /code/illumos-gate/usr/src/common/mpi/mpi-priv.h:303:71: error: right-hand operand of comma expression has no effect [-Werror=unused-value]
     (s_mpv_mul_d_add_prop(MP_DIGITS(a), MP_USED(a), b, MP_DIGITS(c) + off), MP_OKAY)
     ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~^~~~~~~~~~
    /code/illumos-gate/usr/src/common/mpi/mpi.c:2208:5: note: in expansion of macro 's_mp_mul_d_add_offset'
         s_mp_mul_d_add_offset(p, v, x, ix); /* x += p * v * (RADIX ** ix) */
         ^~~~~~~~~~~~~~~~~~~~~
    cc1: all warnings being treated as errors


Related issues

Related to illumos gate - Bug #8660: mpi code checks return value of void functionClosed2017-09-18

Actions
#1

Updated by Dan McDonald about 3 years ago

  • Related to Feature #8600: ZFS channel programs - snapshot added
#2

Updated by Dan McDonald about 3 years ago

  • Related to deleted (Feature #8600: ZFS channel programs - snapshot)
#3

Updated by Dan McDonald about 3 years ago

  • Related to Bug #8660: mpi code checks return value of void function added
#4

Updated by Dan McDonald about 3 years ago

  • Status changed from In Progress to Feedback

Duplicate of #8660

#5

Updated by Dan McDonald about 3 years ago

  • Status changed from Feedback to Closed

Also available in: Atom PDF