Project

General

Profile

Bug #8859

Service pkg/depot fails with error in wsgi

Added by Andreas GrĂ¼ninger almost 3 years ago. Updated almost 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
OI-Userland
Target version:
-
Start date:
2017-11-24
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage

Description

After upgrade pkg/depot fails with:
[Thu Nov 23 17:34:21.653747 2017] [wsgi:error] [pid 1728] (22)Invalid argument: [client 10.xx.xxx.xxx:45507] mod_wsgi (pid=1728): Unable to send request details to WSGI daemon process 'pkgdepot' on '/var/run/pkg/depot/wsgi.1723.0.1.sock'

Old system was from August 2017 with mod_wsgi 4.5.7.
mod_wsgi was updated to 4.5.17.

History

#1

Updated by Andreas GrĂ¼ninger almost 3 years ago

I replaced /usr/apache2/2.4/libexec/mod_wsgi-2.7.so (version 4.5.17) with the binary from version 4.5.7 and pkg/depot works again.

Also available in: Atom PDF