Project

General

Profile

Bug #887

Update to perl 5.10.0 breaks illumos find_elf

Added by Gordon Ross over 8 years ago. Updated over 8 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
2011-04-07
Due date:
% Done:

0%

Estimated time:
Difficulty:
Tags:

Description

After the update to perl 5.10.0 in openindiana/dev-il
my builds of illumos have many lines of build noise:

closedir() attempted on invalid dirhandle DIR at /tank/ws/illumos-fixes/usr/src/tools/proto/root_i386-nd/opt/onbld/bin/find_elf line 303.

My publisher is set to: http://pkg.openindiana.org/dev-il/
The installed perl package is:
pkg:,5.11-0.148:20110327T183613Z


Related issues

Is duplicate of illumos gate - Bug #754: Build of illumos-gate fails with perl-5.10.0 as default perlResolved2011-02-26

Actions

History

#1

Updated by Gordon Ross over 8 years ago

  • Status changed from New to Feedback

Oh, my search in redmine before I filed this did not find: 754.
The problem is understood. It's an illumos tools issue:

Bug #754: Build of illumos-gate fails with perl-5.10.0 as default perl
https://www.illumos.org/issues/754

#2

Updated by Rich Lowe over 8 years ago

  • Status changed from Feedback to Closed

Also available in: Atom PDF