Project

General

Profile

Actions

Bug #889

closed

g11n packages have doubly incorrect facets

Added by Rich Lowe about 10 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Release Engineering
Target version:
-
Start date:
2011-04-07
Due date:
2013-12-10
% Done:

0%

Estimated time:
1.00 h
Difficulty:
Medium
Tags:
pkg

Description

In the pkg.openindiana.org/dev-il various packages from g11n contain 'devel' attributes on various files and directories. Likely, this was intended to be 'facet.devel'.

Further, these are being applied to system directories that do not otherwise have that facet, such as usr/include. It's unclear at present whether that's a good thing:

  1. pkglint will complain about the multiple actions for those directories having differing attributes.
  2. We think that pkg will not remove the directory when change-facet is used (because they're ref counted).

As long as point 2 holds, the application of it to the system directories is not a problem, just causes pkglint noise.

Actions #1

Updated by Ryo Murakawa about 10 years ago

  • Assignee set to OI PKG
Actions #2

Updated by Ken Mays over 7 years ago

  • Due date set to 2013-12-10
  • Status changed from New to Closed
  • Estimated time set to 1.00 h
  • Difficulty set to Medium
  • Tags set to pkg

pkg.openindiana.org/dev-il is now defunct. Closing ticket.

Actions

Also available in: Atom PDF