Project

General

Profile

Feature #8928

Want open source bnx

Added by Robert Mustacchi almost 2 years ago. Updated 8 months ago.

Status:
Closed
Priority:
Normal
Category:
driver - device drivers
Start date:
2017-12-19
Due date:
% Done:

100%

Estimated time:
Difficulty:
Hard
Tags:

Description

Cavium (QLogic) has kindly agreed to open source the bnx driver. The bnx driver is receiving no more updates from them; however, given that it is one of the more commonly encountered closed bin encounters, we should clean it up and import it into illumos and eliminate a closed bin that has many known problems.


Related issues

Is duplicate of illumos gate - Bug #4175: BNX driver vlan/mtu fixResolved2013-10-02

Actions

History

#1

Updated by Electric Monk 8 months ago

  • Status changed from New to Closed
  • % Done changed from 80 to 100

git commit eef4f27b270242808b43b4b23bd161df52839361

commit  eef4f27b270242808b43b4b23bd161df52839361
Author: Robert Mustacchi <rm@joyent.com>
Date:   2019-02-22T21:40:55.000Z

    8928 Want open source bnx
    Reviewed by: Andy Fiddaman <andy@omniosce.org>
    Reviewed by: Toomas Soome <tsoome@me.com>
    Approved by: Richard Lowe <richlowe@richlowe.net>

#2

Updated by Robert Mustacchi 8 months ago

  • Is duplicate of Bug #4175: BNX driver vlan/mtu fix added

Also available in: Atom PDF