Project

General

Profile

Actions

Feature #9041

closed

implement forkpty

Added by Rich Lowe over 4 years ago. Updated 4 months ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
-
Start date:
2018-02-05
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage
Gerrit CR:

Description

We just uncovered a bug with tmux that turns out to be because its implementation of forkpty pushes the tty-related streams modules onto the slave, but when libc is XPG4 or above (__xpg4 is set), so do we.

This breaks the tty arbitrarily (we can't know its size, at the least).

We've talked in the past about implementing forkpty, doing so, and doing it properly, seems like a nice way to save people from having to know about this.


Related issues

Related to illumos gate - Bug #9042: multiples of tty streams modules cause weirdnessClosed2018-02-05

Actions
Is duplicate of illumos gate - Feature #5386: implement openpty(3C), forkpty(3C), and login_tty(3C)NewJoshua M. Clulow2014-12-03

Actions
Actions #1

Updated by Rich Lowe over 4 years ago

  • Related to Bug #9042: multiples of tty streams modules cause weirdness added
Actions #2

Updated by Joshua M. Clulow 4 months ago

  • Is duplicate of Feature #5386: implement openpty(3C), forkpty(3C), and login_tty(3C) added
Actions #3

Updated by Joshua M. Clulow 4 months ago

  • Status changed from New to Duplicate
Actions

Also available in: Atom PDF