Project

General

Profile

Bug #9065

Libgee outdated

Added by Igor Zhukov about 2 years ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
2018-02-07
Due date:
% Done:

100%

Estimated time:
Difficulty:
Medium
Tags:

Description

Any Vala program with --pkg gee-0.8 doesn't work. gee-0.8.vapi was generated with valac 0.20. Regenerate it with current valac.

Code for reprodution:

// main.vala
void main() {}

// how to build
valac --pkg gee-0.8 main.vala

History

#1

Updated by Igor Zhukov about 2 years ago

Just as fast bugfix:
If I copy /usr/share/vala/vapi/gee-0.8.vapi from Linux it works.

Sorry I do not enogth experienced in vala and I do not know how to generate vapi files. :(

My gee-0.8.vapi from Linux: https://yadi.sk/d/FanFuJ_m3SADZN

#2

Updated by Igor Zhukov about 2 years ago

Oh. Of course the packages should be installed:

sudo pkg install vala libgee

#3

Updated by Aurélien Larcher over 1 year ago

  • Assignee set to OI Userland
  • Target version set to Hipster
  • % Done changed from 0 to 100
  • Tags deleted (needs-triage)

0.20.1 was pushed a long while ago.

#4

Updated by Aurélien Larcher over 1 year ago

  • Status changed from New to Resolved

Also available in: Atom PDF