Bug #9178

sasl_plugins: this statement may fall through

Added by Toomas Soome 12 months ago. Updated 9 months ago.

Status:ClosedStart date:2018-02-22
Priority:NormalDue date:
Assignee:Toomas Soome% Done:

100%

Category:lib - userland libraries
Target version:-
Difficulty:Medium Tags:

Description

Issue found by gcc 7 build:

    ../digestmd5.c:5067:5: error: this statement may fall through [-Werror=implicit-fallthrough=]
      if (!serverin) {
         ^
    ../digestmd5.c:5095:5: note: here
         case 3:
         ^~~~
    ../digestmd5.c:5123:16: error: this statement may fall through [-Werror=implicit-fallthrough=]
      ctext->cipher = NULL;
    ../digestmd5.c:5125:5: note: here
         case 2:
         ^~~~

    ../login.c:130:5: error: this statement may fall through [-Werror=implicit-fallthrough=]
      if (clientinlen == 0) {
         ^
    ../login.c:140:5: note: here
         case 2:
         ^~~~

    cc1: all warnings being treated as errors

History

#1 Updated by Electric Monk 9 months ago

  • % Done changed from 90 to 100
  • Status changed from In Progress to Closed

git commit 7a7d534ff7d637c8673694e0ec835c590a6697e5

commit  7a7d534ff7d637c8673694e0ec835c590a6697e5
Author: Toomas Soome <tsoome@me.com>
Date:   2018-05-31T20:22:17.000Z

    9178 sasl_plugins: this statement may fall through
    Reviewed by: Andy Fiddaman <omnios@citrus-it.co.uk>
    Reviewed by: Hans Rosenfeld <rosenfeld@grumpf.hope-2000.org>
    Approved by: Robert Mustacchi <rm@joyent.com>

Also available in: Atom