Project

General

Profile

Feature #9182

pppd: this use of "defined" may not be portable

Added by Toomas Soome over 1 year ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
cmd - userland programs
Start date:
2018-02-22
Due date:
% Done:

90%

Estimated time:
Difficulty:
Medium
Tags:

Description

Issue found by gcc 7 build:

    pppd: this use of "defined" may not be portable

    ipcp.c: In function 'ipcp_up':
    ipcp.c:1546:5: error: this use of "defined" may not be portable [-Werror=expansion-to-defined]
     #if SIFUPFIRST
         ^~~~~~~~~~
    ipcp.c:1546:5: error: this use of "defined" may not be portable [-Werror=expansion-to-defined]
    ipcp.c:1546:5: error: this use of "defined" may not be portable [-Werror=expansion-to-defined]
    ipcp.c:1561:6: error: this use of "defined" may not be portable [-Werror=expansion-to-defined]
     #if !SIFUPFIRST
          ^~~~~~~~~~
    ipcp.c:1561:6: error: this use of "defined" may not be portable [-Werror=expansion-to-defined]
    ipcp.c:1561:6: error: this use of "defined" may not be portable [-Werror=expansion-to-defined]

    ipv6cp.c:1110:5: error: this use of "defined" may not be portable [-Werror=expansion-to-defined]
     #if SIF6UPFIRST
         ^~~~~~~~~~~
    ipv6cp.c:1110:5: error: this use of "defined" may not be portable [-Werror=expansion-to-defined]
    ipv6cp.c:1110:5: error: this use of "defined" may not be portable [-Werror=expansion-to-defined]
    ipv6cp.c:1110:5: error: this use of "defined" may not be portable [-Werror=expansion-to-defined]
    ipv6cp.c:1116:6: error: this use of "defined" may not be portable [-Werror=expansion-to-defined]
     #if !SIF6UPFIRST
          ^~~~~~~~~~~
    ipv6cp.c:1116:6: error: this use of "defined" may not be portable [-Werror=expansion-to-defined]
    ipv6cp.c:1116:6: error: this use of "defined" may not be portable [-Werror=expansion-to-defined]
    ipv6cp.c:1116:6: error: this use of "defined" may not be portable [-Werror=expansion-to-defined]
    ipv6cp.c: In function 'ipv6cp_up':
    ipv6cp.c:1212:6: error: this use of "defined" may not be portable [-Werror=expansion-to-defined]
     #if !SIF6UPFIRST
          ^~~~~~~~~~~
    ipv6cp.c:1212:6: error: this use of "defined" may not be portable [-Werror=expansion-to-defined]
    ipv6cp.c:1212:6: error: this use of "defined" may not be portable [-Werror=expansion-to-defined]
    ipv6cp.c:1212:6: error: this use of "defined" may not be portable [-Werror=expansion-to-defined]
    ipv6cp.c:1236:5: error: this use of "defined" may not be portable [-Werror=expansion-to-defined]
     #if SIF6UPFIRST
         ^~~~~~~~~~~
    ipv6cp.c:1236:5: error: this use of "defined" may not be portable [-Werror=expansion-to-defined]
    ipv6cp.c:1236:5: error: this use of "defined" may not be portable [-Werror=expansion-to-defined]
    ipv6cp.c:1236:5: error: this use of "defined" may not be portable [-Werror=expansion-to-defined]

    cc1: all warnings being treated as errors

History

#1

Updated by Toomas Soome over 1 year ago

  • Status changed from In Progress to Closed
  • Tracker changed from Bug to Feature

duplicate of 9306

Also available in: Atom PDF