Project

General

Profile

Bug #9183

pkg update in newly installed OI renders system unbootable

Added by Tony Albers over 1 year ago. Updated over 1 year ago.

Status:
New
Priority:
Urgent
Assignee:
-
Category:
-
Target version:
-
Start date:
2018-02-23
Due date:
% Done:

0%

Estimated time:
Difficulty:
Hard
Tags:
needs-triage

Description

1. Install OI via either iso or usb, version 20171031
2. open a terminal, become root and run 'pkg update'
3. reboot.
4. system hangs at bootloader saying "Can't find /boot/zfsloader"

The workarounds mentioned here:
https://www.openindiana.org/pipermail/openindiana-discuss/2017-February/020291.html
and here:
https://wiki.openindiana.org/oi/MBR+reinstall+after+illumos+loader+update

Does NOT work.

System can be booted from USB/ISO, escaped to loader prompt and boot environment(both old and new) activated and booted(workaround 2 in the mail in the first link above).


Related issues

Related to illumos gate - Bug #9167: gptzfsboot and zfsloader can't find slices inside PTABLE_VTOC label after 9099Closed2018-02-21

Actions

History

#1

Updated by Tony Albers over 1 year ago

Tony Albers wrote:

1. Install OI via either iso or usb, version 20171031
2. open a terminal, become root and run 'pkg update'
3. reboot.
4. system hangs at bootloader saying "Can't find /boot/zfsloader"

The workarounds mentioned here:
https://www.openindiana.org/pipermail/openindiana-discuss/2017-February/020291.html
and here:
https://wiki.openindiana.org/oi/MBR+reinstall+after+illumos+loader+update

Does NOT work.

System can be booted from USB/ISO, escaped to loader prompt and boot environment(both old and new) activated and booted(workaround 2 in the mail in the first link above).

It should be noted that a fresh install followed by changing root's expired password, doing 'pkg refresh --full' and then 'pkg image-update -v' work as expected and the system works as expected after a reboot. So the above issue is somehow related to running 'pkg update' instead of 'pkg image-update'

#2

Updated by Tony Albers over 1 year ago

  • Related to Bug #9167: gptzfsboot and zfsloader can't find slices inside PTABLE_VTOC label after 9099 added

Also available in: Atom PDF