Project

General

Profile

Actions

Bug #9245

closed

zfs-test failures: slog_013_pos and slog_014_pos

Added by Brad Lewis over 4 years ago. Updated about 4 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Start date:
2018-03-06
Due date:
% Done:

100%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage
Gerrit CR:

Description

Test 13 would fail because of attempts to zpool destroy -f a pool that was still busy. Changed those calls to destroy_pool which does a retry loop, and the problem is no longer reproducible. Also removed some non functional code in the test which is why it was originally commented out by placing it after the call to log_pass.

Test 14 would fail because sometimes the check for a degraded pool would complete before the pool had changed state. Changed the logic to check in a loop with a timeout and the problem is no longer reproducible.

Actions #1

Updated by Electric Monk about 4 years ago

  • Status changed from New to Closed
  • % Done changed from 0 to 100

git commit 20596fe40e947343459994c3b1bcb68f7c0df52e

commit  20596fe40e947343459994c3b1bcb68f7c0df52e
Author: John Wren Kennedy <john.kennedy@delphix.com>
Date:   2018-05-17T13:49:34.000Z

    9245 zfs-test failures: slog_013_pos and slog_014_pos
    Reviewed by: Matt Ahrens <matt@delphix.com>
    Reviewed by: Chris Williamson <chris.williamson@delphix.com>
    Reviewed by: Yuri Pankov <yuripv@yuripv.net>
    Approved by: Dan McDonald <danmcd@joyent.com>

Actions

Also available in: Atom PDF