Project

General

Profile

Bug #9254

BTX halted at boot time

Added by Priyadarshan G.D. over 2 years ago. Updated 2 months ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
2018-03-09
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage

Description

Hi,

I have successfully installed OpenIndiana Hipster 2017.10 Live via USB image on a ThinkPad W541.

Now, I am trying to install to 2 different workstations, using same USB stick:

- HP z620 with Xeon E5
- Asus X399 motherboard with AMD 1950X Threadripper

After a few seconds, both machines give same message "BTX halted"

See attached screehsots.

I tried setting BIOS to legacy mode and UEFI mode. Also, I am booting from a USB 2 port, in case that still matters.

I though something could be wrong with the USB image, but same image boots fine on the ThinkPad.

Also, I tried to image the same USB stick with FReeBSD 11.1-RELEASE USB image.

I am able to boot the FreeBSD installer, on both machines, both in legacy mode and UEFI mode.

Is there anything I need to do in order to have the image boot?

Please, could you let me know what I can do to debug this issue?


Files

hp-z620-xeon-e5.jpg (673 KB) hp-z620-xeon-e5.jpg Priyadarshan G.D., 2018-03-09 08:11 AM
asus-x399-amd-threadripper-1950x.jpg (666 KB) asus-x399-amd-threadripper-1950x.jpg Priyadarshan G.D., 2018-03-09 08:11 AM
#1

Updated by Priyadarshan G.D. over 2 years ago

I spent several hours yesterday and today, playing around with bios settings on both machines.

It seems there is no much hope with Asus X399 motherboard, even switching to bios-Legacy mode and disabling ACPI.

I had more success with the HP Z620 (late 2012 model).

By setting bios SATA to IDE compatibility mode, the OpenIndiana Live USB finally booted.

That system is running a Xeon E5 1650, with no builtin graphics, but it has an nvidia GeForce card.

After a few seconds, lightdm fails, and issue message "default failed: transitioned to maintenance". Then I am dropped in openindiana console login.

Still, I finally got to boot!

But, there is another issue:

Unfortunately, when I booted the Live USB image, it forced the HP Z620 worstation, which was fine booting FreeBSD via UEFI, to Bios-legacy mode, effectively botching the boot disk.

Mind you, I was not installing it. Just the mere running of the Live USB image changed the boot setup to legacy mode and leaving a boitched FreeBSD install.

Unfortunately, we do not have any non-UEFI machines here, so I will need to wait to play more with OI when UEFI install image will be available.

#2

Updated by Priyadarshan G.D. over 2 years ago

This ticket could be probably be split in two subtasks:

- OpenIndiana cannot boot on Asus (and possibly all) X399-type motherboards, possibly due to strong UEFI nature.

- At boot time, OpenIndiana Live USB image seems to force local bios to legacy mode, thus altering already present EFI installs, preventing them for future booting.

I am available to test any image, but I am not at all expert with boot loaders.

#3

Updated by Yuri Pankov over 2 years ago

What does the following mean exactly?

it forced the HP Z620 worstation, which was fine booting FreeBSD via UEFI, to Bios-legacy mode

#4

Updated by Priyadarshan G.D. over 2 years ago

The workstation was booting fine via UEFI. FreeBSD 11 installed on the only SSD disk (Samsung 850 Pro)

- In order to boot Live OI image, I changed Bios SATA setting, from AHCI to IDE compatible mode
- Finally I was able to boot from Live OI stick
- ...although lightdm failed (but that is fine, I do not think it is of cocnern here)

- Then, I powered off the machine, extracted the USB stick, and reverted Bios setting, from IDE compatibility to AHCI mode, as it was before.

- But, when I tried to boot into usual FreeBSD, machine would not find the bootloader anymore, giving "No disk found" error.

Surely enough, from Bios, I cannot see any UEFI devices anymore, (while before I could see the Samsung 850)

If I boot from FreeBSD Live rescue disk, I can see the Samsung 850, and I can import its ZFS pool

Since the only thing I did was to boot from OI Live image (without even reaching the final step, that is, login screen), I am thinking somehow OI Live image forced a legacy-bios boot mode on the only available boot disk, which was installed as UEFI (GPT) only.

I could try to reproduce these steps, but I do not want to affect other workstations here, so I would gave to reinstall FreeBSD on this one and try again.

#5

Updated by Toomas Soome 2 months ago

Priyadarshan G.D. wrote:

The workstation was booting fine via UEFI. FreeBSD 11 installed on the only SSD disk (Samsung 850 Pro)

- In order to boot Live OI image, I changed Bios SATA setting, from AHCI to IDE compatible mode
- Finally I was able to boot from Live OI stick
- ...although lightdm failed (but that is fine, I do not think it is of cocnern here)

- Then, I powered off the machine, extracted the USB stick, and reverted Bios setting, from IDE compatibility to AHCI mode, as it was before.

- But, when I tried to boot into usual FreeBSD, machine would not find the bootloader anymore, giving "No disk found" error.

Surely enough, from Bios, I cannot see any UEFI devices anymore, (while before I could see the Samsung 850)

If I boot from FreeBSD Live rescue disk, I can see the Samsung 850, and I can import its ZFS pool

Since the only thing I did was to boot from OI Live image (without even reaching the final step, that is, login screen), I am thinking somehow OI Live image forced a legacy-bios boot mode on the only available boot disk, which was installed as UEFI (GPT) only.

I could try to reproduce these steps, but I do not want to affect other workstations here, so I would gave to reinstall FreeBSD on this one and try again.

Is this issue still actual or can it be closed?

#6

Updated by Priyadarshan G.D. 2 months ago

Is this issue still actual or can it be closed?

It can be closed.

I could not fix it with oi, so I switched to OmniOS first, then SmartOS.

#7

Updated by Andreas Wacknitz 2 months ago

  • Status changed from New to Closed

Also available in: Atom PDF