Project

General

Profile

Bug #9280

Assertion failure while running removal_with_ganging test with 4K devices

Added by Brad Lewis over 1 year ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Start date:
2018-03-13
Due date:
% Done:

100%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage

Description

We hit a panic in the removal_with_ganging test using vdevs with 4k ashift for testing.

The problem is that the test intentionally induces ganging in allocations as small as 4K, but failing a minimum-size allocation (4K in this case) is not permitted. We should change the test to only gang 8K and larger, or make it dynamic based on the max ashift in the pool.

History

#1

Updated by Electric Monk over 1 year ago

  • % Done changed from 0 to 100
  • Status changed from New to Closed

git commit 243952c7eeef020886e3e2e3df99a513df40584a

commit  243952c7eeef020886e3e2e3df99a513df40584a
Author: Matt Ahrens <Matt.Ahrens@delphix.com>
Date:   2018-03-21T15:26:16.000Z

    9280 Assertion failure while running removal_with_ganging test with 4K devices
    Reviewed by: George Wilson <george.wilson@delphix.com>
    Reviewed by: John Kennedy <john.kennedy@delphix.com>
    Approved by: Garrett D'Amore <garrett@damore.org>

Also available in: Atom PDF