Project

General

Profile

Bug #9312

ctf: be less clever about skipping 'extern' variables declarations

Added by Toomas Soome over 1 year ago. Updated 6 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
tools - gate/build tools
Start date:
2018-03-19
Due date:
% Done:

100%

Estimated time:
Difficulty:
Medium
Tags:

Description

Work by Richard Lowe.

  • We used to skip variables that were die_isdecl() But GCC 7 emits
  • only these when a concrete definition follows an extern definition
  • in the same CU.

Related issues

Related to illumos gate - Feature #9996: use GCC 7 as default primary compilerClosed2018-11-21

Actions

History

#1

Updated by John Levon 10 months ago

rm pointed me to this, which I think is likely to be the old-tools equivalent of
https://smartos.org/bugview/OS-7270

If so, then the fix up on RB doesn't seem right to me, and it should instead
be doing something very similar to the fix I suggested above.

If nobody gets to it before me, I will pick this up...

#2

Updated by Igor Kozhukhov 10 months ago

John Levon wrote:

rm pointed me to this, which I think is likely to be the old-tools equivalent of
https://smartos.org/bugview/OS-7270

If so, then the fix up on RB doesn't seem right to me, and it should instead
be doing something very similar to the fix I suggested above.

If nobody gets to it before me, I will pick this up...

i'd like to see it fixed with Joyent ctf tools, because dtrace with kernel not working if it built by new gcc6/7
i can confirm: with this update and gcc6 build with current ctf tools in illumos - all works fine.
if you need additional checks with updates with Joyent ctf tools - just ping me on #illumos IRC or by email - i'd like to help with tests

#3

Updated by John Levon 8 months ago

  • Related to Feature #9996: use GCC 7 as default primary compiler added
#4

Updated by Electric Monk 6 months ago

  • Status changed from In Progress to Closed
  • % Done changed from 90 to 100

git commit 2dc5cbd37af38054ac6aab88a3ecee22a13ed2eb

commit  2dc5cbd37af38054ac6aab88a3ecee22a13ed2eb
Author: John Levon <john.levon@joyent.com>
Date:   2019-01-18T02:17:01.000Z

    9312 ctf: be less clever about skipping 'extern' variables declarations
    9864 DWARF->CTF enum conversion needs to be careful of sign
    Reviewed by: Toomas Soome <tsoome@me.com>
    Reviewed by: Andy Fiddaman <af@citrus-it.net>
    Reviewed by: Igor Kozhukhov <igor@dilos.org>
    Approved by: Dan McDonald <danmcd@joyent.com>

Also available in: Atom PDF