Project

General

Profile

Actions

Bug #9447

closed

NFS unmount is slow

Added by Marcel Telka over 3 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
nfs - NFS server and client
Start date:
2018-04-10
Due date:
% Done:

100%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage
Gerrit CR:

Description

The NFS unmount operation is slow at the NFS client when there is a non-trivial amount of files. With thousands of file systems mounted via NFSv4 (and mirror mounts) this can cause the NFS harvester to consume one full CPU to do its work. The problem is visible at NFSv2 and NFSv3 clients too.


Files

repro-slow-nfs-umount (2.23 KB) repro-slow-nfs-umount Marcel Telka, 2018-04-10 08:19 AM
Actions

Also available in: Atom PDF