Project

General

Profile

Bug #9451

Can't unselect USB disk in Text Installer's Disk dialog

Added by Michal Nowak over 1 year ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
2018-04-10
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage

Description

Built installation images yesterday and in the Text Installer's Disk dialog (on USB image) SCSI disk sized 500 MB is selected and can't be unselected as I am unable to move the line pointer on it: https://openqa.oi.mnowak.cz/tests/2881#step/bootloader_textmode/19

See also the attached image.

This used to work on March 16th: https://openqa.oi.mnowak.cz/tests/2752#step/bootloader_textmode/18

The USB image is here: https://openqa.oi.mnowak.cz/tests/2881/asset/iso/OI-hipster-minimal-20180409.usb


Files

disks.png (26.2 KB) disks.png Michal Nowak, 2018-04-10 05:00 PM

History

#1

Updated by Alexander Pyhalov over 1 year ago

The issue is that installer auto-selects first disk in list, if no disk is selected, but can disable this entry if it's size is too small. So, we should auto-select first selectable disk.
Possible fix is https://github.com/OpenIndiana/slim_source/pull/42/files

#2

Updated by Michal Nowak over 1 year ago

All problems are gone now. Verified with just built minimal image. Thank you.

#3

Updated by Alexander Pyhalov over 1 year ago

  • Status changed from New to Resolved

Also available in: Atom PDF