Project

General

Profile

Actions

Bug #9513

closed

SBCL dumps core (SIGSEGV)

Added by Matthew Trower over 3 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
2018-04-29
Due date:
% Done:

10%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage

Description

After pkg update yesterday...

admin@saturn:/home/admin$ sbcl
This is SBCL 10423.-23e379e4e-dirty, an implementation of ANSI Common Lisp.
More information about SBCL is available at <http://www.sbcl.org/>.

SBCL is free software, provided as is, with absolutely no warranty.
It is mostly in the public domain; some portions are provided under
BSD-style licenses.  See the CREDITS and COPYING files in the
distribution for more information.
Segmentation Fault (core dumped)
admin@saturn:/home/admin$ file core
core:           ELF 32-bit LSB core file 80386 Version 1, from 'sbcl'

At 42MB, I can't attach the core file, but here's a simple backtrace: [[https://pastebin.com/w9Dhr7Js]]

Let me know if I can assist further in some way.


Related issues

Related to illumos gate - Bug #9600: LDT still not happy under KPTIClosedJohn Levon2018-06-14

Actions
Actions #1

Updated by Alexander Pyhalov over 3 years ago

The issue is evidently caused by KPTI patchset. Disabling kpti is not enough to fix it.
Later sbcl versions are not affected, and so package should be fixed by https://github.com/OpenIndiana/oi-userland/pull/4153 .
However, underlying issue needs investigation.

Actions #2

Updated by Alexander Pyhalov over 3 years ago

  • % Done changed from 0 to 10
Actions #3

Updated by Alexander Pyhalov over 3 years ago

It seems, disabling threading in sbcl is enough to fix it.

Actions #4

Updated by Gergő Mihály Doma over 3 years ago

  • Related to Bug #9600: LDT still not happy under KPTI added
Actions #5

Updated by Gergő Mihály Doma over 3 years ago

Related issue #9600 added (duplicate?).

Actions #6

Updated by John Levon almost 3 years ago

This was long since fixed

Actions #7

Updated by Rich Lowe over 2 years ago

  • Status changed from New to Closed
Actions

Also available in: Atom PDF