Project

General

Profile

Actions

Bug #9652

closed

loader.efi: use explicit lea in multiboot_tramp.S

Added by Toomas Soome about 3 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
bootloader
Start date:
2018-07-12
Due date:
% Done:

100%

Estimated time:
Difficulty:
Medium
Tags:
Gerrit CR:

Description

We want to load addresses for the symbols, so we can actually use the memory relative to %rip. I guess the initial version was working by "accident", but using explicit lea instruction should make it behave as intended...

Actions #1

Updated by Electric Monk about 3 years ago

  • Status changed from In Progress to Closed
  • % Done changed from 90 to 100

git commit 3dd539e3fd0ab91cff2829d6bc9105d44a90a037

commit  3dd539e3fd0ab91cff2829d6bc9105d44a90a037
Author: Toomas Soome <tsoome@me.com>
Date:   2018-07-17T18:28:25.000Z

    9652 loader.efi: use explicit lea in multiboot_tramp.S
    Reviewed by: Yuri Pankov <yuripv@yuripv.net>
    Reviewed by: Andy Fiddaman <omnios@citrus-it.co.uk>
    Approved by: Robert Mustacchi <rm@joyent.com>

Actions

Also available in: Atom PDF