Project

General

Profile

Actions

Bug #9686

closed

OpenIndiana uses 1.3 GB doing nothng

Added by Bill Chatfield almost 3 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Desktop (JDS)
Target version:
Start date:
2018-07-31
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage

Description

If you just boot up the operating system to the desktop, it's using 1.3 GB of RAM. This is twice as much RAM as Fedora Linux 28 uses with the Gnome 3 desktop and 4 times as much as Solaris 11, which uses a little over 300 MB.

The fact that it uses so much RAM makes it pretty impossible for me to run it and do anything useful with it in VirtualBox on my 8 GB laptop. Solaris 11 however works fine.

I'm referring to OpenIndiana version 20180427.

I'm not able to determine exactly what process is using all that RAM. If you have some ideas on how to do that I can try them.


Files

VirtualBox_OpenIndiana_31_07_2018_08_43_06.png (585 KB) VirtualBox_OpenIndiana_31_07_2018_08_43_06.png Picture of desktop with System Monitor showing 1.3 GB used Bill Chatfield, 2018-07-31 12:52 PM
Actions #1

Updated by Michal Nowak almost 3 years ago

It seems to me that those 1.3 GB include ZFS ARC ("page cache") as well. You can have a better look via top including what holds that memory. There are ways to tune the ARC but might be just easier to add a bit more of memory to the VM. Is something in particular not working?

Actions #2

Updated by Bill Chatfield almost 3 years ago

It seemed like there was a problem just based on the amount of memory that was being used. I was expecting memory usage to be similar to Solaris since they're similar systems. A Linux system with Mate would use about 500MB on startup. I didn't really try starting a browser or Java IDE as there wasn't enough memory left to run them.

Top is saying ARC is using 542MB total.

Actions #3

Updated by Bill Chatfield almost 3 years ago

Here's the full top output sorted by memory usage:

load averages:  0.02,  0.02,  0.02;               up 0+00:58:22        21:40:19
88 processes: 87 sleeping, 1 on cpu
CPU states: 95.0% idle,  2.2% user,  2.8% kernel,  0.0% iowait,  0.0% swap
Kernel: 395 ctxsw, 22 trap, 323 intr, 834 syscall, 3 flt
Memory: 2048M phys mem, 687M free mem, 871M total swap, 871M free swap
ARC:    542M Total, 405M MRU, 68M MFU, 32K Anon, 2060K Header, 67M Other

   PID USERNAME NLWP PRI NICE  SIZE   RES STATE    TIME    CPU COMMAND
  1167 bill        3  59    0  225M  212M sleep    0:17  1.13% Xorg
  1261 bill        5  59    0  107M   25M sleep    0:01  0.03% mate-settings-d
  1293 bill        3  59    0  104M   23M sleep    0:00  0.00% mate-volume-con
  1299 bill        3  59    0   78M 6640K sleep    0:00  0.00% pulseaudio
  1266 bill        4  59    0   66M   48M sleep    0:01  0.00% caja
  1263 bill        4  59    0   59M   44M sleep    0:01  0.00% mate-panel
  1332 bill        4  59    0   47M   28M sleep    0:04  1.14% mate-terminal
  1292 bill        8  59    0   44M   14M sleep    0:00  0.00% tracker-store
  1305 bill        4  12   19   43M   13M sleep    0:00  0.00% tracker-miner-f
  1297 bill       14  12   19   42M   12M sleep    0:00  0.00% tracker-extract
  1304 bill        4  12   19   42M   12M sleep    0:00  0.00% tracker-miner-a
  1296 bill        4  12   19   41M   11M sleep    0:00  0.00% tracker-miner-u
  1286 bill        4  59    0   41M   24M sleep    0:00  0.00% clock-applet
  1262 bill        4  59    0   40M   24M sleep    0:02  0.25% marco
  1276 bill        3  59    0   38M   26M sleep    0:00  0.00% time-slider-not
  1281 bill        4  59    0   37M   21M sleep    0:00  0.00% mate-power-mana
  1271 bill        4  59    0   37M   21M sleep    0:00  0.05% wnck-applet
  1273 bill        3  59    0   35M   20M sleep    0:00  0.00% trashapplet
  1219 bill        4  59    0   34M   17M sleep    0:00  0.00% mate-session
  1288 bill        3  59    0   34M   18M sleep    0:00  0.00% notification-ar
  1284 bill        4  59    0   30M   19M sleep    0:00  0.00% nwam-manager
   755 root       27  59    0   29M   22M sleep    0:02  0.00% fmd
  1303 bill        2  59    0   24M   14M sleep    0:00  0.00% isapython2.7
  1259 bill        4  59    0   11M 6480K sleep    0:00  0.00% gnome-keyring-d
    11 root       19  59    0   11M 9760K sleep    0:19  0.00% svc.configd
  1302 bill        3  59    0   10M 6900K sleep    0:01  0.19% xscreensaver
  1214 root        3  59    0 9836K 6708K sleep    0:00  0.00% lightdm
  1179 root        1  59    0 9780K 1248K sleep    0:00  0.00% sshd
  1131 root        3  59    0 9296K 6032K sleep    0:00  0.00% lightdm

Actions #4

Updated by Michal Nowak almost 3 years ago

Thanks Bill. What I see is this: 2048 (phys mem) − 542 (ARC) − 687 (free mem) = 819 MB of allocated RAM. I guess we could do better, but unless something actually does not work... Bear in mind that you also have 871 MB of SWAP, that is 1690 MB of free virtual memory, plus I guess ARC should adapt to various pressures. Should be just enough to start Firefox.

Actions #5

Updated by Bill Chatfield almost 3 years ago

I guess this is an issue with me not being familiar with ZFS systems. Would it be better on a low-memory desktop system to use something other than ZFS? Can UFS or something else be used? What would your recommendation be?

Actions #6

Updated by Yuri Pankov almost 3 years ago

Well, there's a saying "unused memory is wasted memory", so "high" memory utilization on a what seems to be idle system doesn't tell much (if anything). What real issue are you seeing here; are the processes getting killed because of RAM/swap shortage? Is the system swapping too much?

Actions #7

Updated by Michal Nowak almost 3 years ago

Nope, without ZFS our feature set is gone. Low-memory systems, like your's, should work, but they'll be just that ... low-performance systems. I might be wrong but Tribblix can be installed to UFS.

Actions #8

Updated by Bill Chatfield almost 3 years ago

Thanks for the replies. Nothing is really broken. I guess it just looked broken to me. Possibly my fear is based on my experience with Linux where once you start swapping large apps like Firefox or Eclipse, you're pretty much done and you can't do anything useful. But, I will go forward and see how it works. I may try increasing the ram but as my host system is Linux, that gets back to my fear of running out of ram.

Actions #9

Updated by Bill Chatfield almost 3 years ago

It is hanging/crashing. I increased the ram to 3GB, but I get the same behavior. I'm not sure if the problem is OI or VirtualBox. But, Solaris 11 seems to run OK in a 2GB VirtualBox. The problem still could be with VirtualBox though. I lose control of my host system when OI hangs so that kind of makes me think there's a problem with VirtualBox. I've used KVM with Boxes also and its performance is even worse, not to run OI but other Linuxes.

I was running System Monitor and "sudo pkg install hexchat" two times when it hung/crashed. It hangs up for several minutes and then the VM disappears or Linux/Gnome tells me its not responding.

I could try to collect some information but not sure what to do.

Actions #10

Updated by Toomas Soome almost 3 years ago

Bill Chatfield wrote:

It is hanging/crashing. I increased the ram to 3GB, but I get the same behavior. I'm not sure if the problem is OI or VirtualBox. But, Solaris 11 seems to run OK in a 2GB VirtualBox. The problem still could be with VirtualBox though. I lose control of my host system when OI hangs so that kind of makes me think there's a problem with VirtualBox. I've used KVM with Boxes also and its performance is even worse, not to run OI but other Linuxes.

I was running System Monitor and "sudo pkg install hexchat" two times when it hung/crashed. It hangs up for several minutes and then the VM disappears or Linux/Gnome tells me its not responding.

I could try to collect some information but not sure what to do.

Please check if you are using IDE disk (cmdk device seen in format output). If yes, change it to sata or scsi.

Used memory by itself is not problem (esp if used by arc), but very slow disk IO (like one you get with cmdk) is huge issue.

Actions #11

Updated by Bill Chatfield almost 3 years ago

That is very possible. I will check that tonight. Thanks for the tip.

Actions #12

Updated by Michal Nowak almost 3 years ago

Also there is some information about OI in virtualized environments in our handbook: http://docs.openindiana.org/handbook/getting-started/#booting-the-hipster-installer

Actions #13

Updated by Bill Chatfield almost 3 years ago

I have reinstalled. I specified a partition instead of "whole disk" this time. It seems to be working without hanging or crashing now.

Actions #14

Updated by Aurélien Larcher almost 3 years ago

  • Status changed from New to Closed
Actions

Also available in: Atom PDF