Project

General

Profile

Bug #970

Graphics Card ...

Added by Georgios Papadopoulos over 8 years ago. Updated over 7 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
Category:
Drivers
Target version:
-
Start date:
2011-04-27
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage

Description

Hello,

I do know that I raise a controversial issue, regarding graphics cards, but the reason is twofold: on one hand I would like to understand why a open source driver doesn't work and on the other to make a suggestion (if I may).

My Toshiba Satellite A300D-14P laptop come with an ATi Radeon HD 3200 (I think, a "mobility radeon"). Now, the Device Utility does recognize it and in the package repositories, I can find the corresponding driver. The problem is that is doesn't work: everything is quite blur and the scrolling (say in a browser) is simply awful.

I understand that only nVidia cards are supported, but (again, if I may) I think that OI could give a chance to those systems which have other cards.

Many thanks in advance.


Related issues

Related to OpenIndiana Distribution - Feature #2954: ATI Radeon 6.14.6 driverClosed2012-06-302012-07-31

Actions

History

#1

Updated by Ryo Murakawa over 8 years ago

  • Assignee set to Ryo Murakawa

Hi, My laptop Thinkpad x100e has same RADEON HD3200. I use the driver vgatext. So have you tried this?

#2

Updated by Ryo Murakawa over 8 years ago

  • Assignee changed from Ryo Murakawa to OI Caiman
  • Tags set to needs-triage

I want to add this driver to the repository. So I assign this to OI Caiman.

#3

Updated by Georgios Papadopoulos over 8 years ago

Hello !

Well, according to Device Driver Utility, I do use (by default (?)) the vgatext driver. But as I have written above, everything is quite blur and the scrolling (say in a browser) is simply awful. Moreover, many fonts seem to have a "granular" structure.
Are you satisfied with your that driver?

At this point, I have to say that a few months ago, when I tested the LiveCD of OI_147, everything was working (e.g., Compiz). So perhaps, we should find that driver...

#4

Updated by Alan Coopersmith over 8 years ago

You can't have had compiz running on a Radeon HD3200 on OpenIndiana on OI_147 LiveCD or any other version - only Intel & Nvidia drivers have been ported to the Solaris kernel to provide the necessary 3-D acceleration for compiz. There is an open source Radeon HD driver that could be ported, but it's not simply a rebuild, but a multi-month full-time effort, to port kernel-level graphics drivers, since there's so much difference in the kernel interfaces.

#5

Updated by Georgios Papadopoulos over 8 years ago

I might be mistaken, for, that period I had been trying various liveCDs. Yet, I remember that Compiz did work (perhaps not full functionality -this part I do not remember), while now it does not.

#6

Updated by Julian Wiesener about 8 years ago

  • Status changed from Feedback to Rejected

we're currently not adding Radeon HD3200, driver

#7

Updated by Ken Mays over 7 years ago

  • Tracker changed from Support to Bug
  • Difficulty set to Medium

Also available in: Atom PDF