Project

General

Profile

Actions

Bug #9748

closed

ucode shouldn't need install step

Added by Robert Mustacchi over 3 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Normal
Category:
kernel
Start date:
2018-08-16
Due date:
% Done:

100%

Estimated time:
Difficulty:
Medium
Tags:
Gerrit CR:

Description

Today the micrcode is shipped by taking a file that has a text form of the micrcode and as part of bootadm operations transforming that into something that we can consume as part of the kernel.

This is problematic in few different areas:

1. Intel is no longer providing such a file
2. When building an image that's not through the boot archive such as install media, that no longer exists
3. This allows us to update or roll back individual platforms microcode files

As part of this we move all the microcode files to data/ and record where they came from.


Related issues

Is duplicate of illumos gate - Bug #11843: update Intel microcode to 20190918ClosedJohn Levon

Actions
Actions #1

Updated by Andy Fiddaman almost 2 years ago

  • Is duplicate of Bug #11843: update Intel microcode to 20190918 added
Actions #2

Updated by Andy Fiddaman almost 2 years ago

  • Status changed from New to Closed

This was done under 11843.

Actions

Also available in: Atom PDF