Project

General

Profile

Bug #9751

Allocation throttling misplacing ditto blocks

Added by Alexander Motin about 1 year ago. Updated 4 months ago.

Status:
Closed
Priority:
Normal
Category:
zfs - Zettabyte File System
Start date:
2018-08-16
Due date:
% Done:

100%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage

Description

During synthetic random write benchmarks I found many secondary and tertiary block copies allocations form the same vdevs (more then 10% of all allocations!):

                1          4618459
                2           667430
                3              420

                1          4605120
                2           672441
                3              346

                1          4635516
                2           663064
                3              760

That at the end caused some allocation issues I addressed in #9738. Digging toward the source I found that the poor allocation is caused by allocation throttling. I suppose periodically under the heavy load one or another random disk becomes the only one with allocations available, and starts collecting all ditto blocks. Simple patch I made to relax allocation of secondary and tertiary blocks radically fixed the allocation issue, and seems even increased performance a bit:

                1          6222858

                1          6135604

                1          6062702

History

#2

Updated by Electric Monk 4 months ago

  • Status changed from In Progress to Closed
  • % Done changed from 0 to 100

git commit dbcaafbddbc82f9a7b3310551c4bcdb862b2515a

commit  dbcaafbddbc82f9a7b3310551c4bcdb862b2515a
Author: Alexander Motin <mav@FreeBSD.org>
Date:   2019-05-30T16:46:52.000Z

    9751 Allocation throttling misplacing ditto blocks
    Portions contributed by: Kody Kantor <kody.kantor@joyent.com>
    Reviewed by: Pavel Zakharov <pavel.zakharov@delphix.com>
    Reviewed by: Matt Ahrens <matt@delphix.com>
    Reviewed by: George Wilson <george.wilson@delphix.com>
    Approved by: Gordon Ross <gwr@nexenta.com>

Also available in: Atom PDF