Project

General

Profile

Actions

Bug #9754

closed

grub: recent gcc needs -fno-reorder-functions

Added by Toomas Soome almost 4 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
bootloader
Start date:
2018-08-17
Due date:
% Done:

100%

Estimated time:
Difficulty:
Bite-size
Tags:
Gerrit CR:

Description

Recent gcc do reorder functions (when there is a main() ?) and this does break the special builds like grub stage2 (or loader for that matter). Use -fno-reorder-functions to stop it (the alternate is to use linker map).


Related issues

Is duplicate of illumos gate - Bug #6482: [PATCH] GRUB won't boot when built with GCC 5ClosedAndrew Stormont2015-11-26

Actions
Actions #1

Updated by Electric Monk almost 4 years ago

  • Status changed from In Progress to Closed
  • % Done changed from 90 to 100

git commit e153cda9f9660e385e8f468253f80e59f5d454d7

commit  e153cda9f9660e385e8f468253f80e59f5d454d7
Author: Toomas Soome <tsoome@me.com>
Date:   2018-08-20T17:36:29.000Z

    9754 grub: recent gcc needs -fno-reorder-functions
    Reviewed by: Igor Kozhukhov <igor@dilos.org>
    Reviewed by: Andrew Stormont <andyjstormont@gmail.com>
    Reviewed by: Yuri Pankov <yuripv@yuripv.net>
    Approved by: Dan McDonald <danmcd@joyent.com>

Actions #2

Updated by Andrew Stormont over 3 years ago

  • Is duplicate of Bug #6482: [PATCH] GRUB won't boot when built with GCC 5 added
Actions

Also available in: Atom PDF