Project

General

Profile

Bug #9776

mandoc(1) does not support an ERRORS section for 7I man pages

Added by Jason King over 1 year ago. Updated about 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
cmd - userland programs
Start date:
2018-08-30
Due date:
% Done:

100%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage

Description

While converting some man pages in section 7I, I discovered that mandoc(1) does not allow section 7I to have an ERRORS section:

mandoc: usr/src/man/man7i/dsp.7i:520:2: WARNING: unexpected section: Sh ERRORS for 2, 3, 4, 9 only

Almost certainly the issue is that the BSDs do not have a 7I section, so when we imported it, we never added support.

History

#1

Updated by Electric Monk about 1 year ago

  • % Done changed from 0 to 100
  • Status changed from New to Closed

git commit f6b3f249ec2ef9f94d38d7a7c1b4fcbe2e891933

commit  f6b3f249ec2ef9f94d38d7a7c1b4fcbe2e891933
Author: Jason King <jason.king@joyent.com>
Date:   2019-02-01T19:02:01.000Z

    9776 mandoc(1) does not support an ERRORS section for 7I man pages
    9778 Convert agpgart_io(7I) to mandoc
    9779 Convert audio(7I) to mandoc
    9780 Convert cdio(7I) to mandoc
    9777 Convert dsp(7I) to mandoc
    Reviewed by: Gergő Mihály Doma <domag02@gmail.com>
    Approved by: Richard Lowe <richlowe@richlowe.net>

Also available in: Atom PDF