Project

General

Profile

Actions

Feature #9852

closed

enable ld(1) guidance and deflib assertions for the illumos build

Added by Rich Lowe about 3 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
tools - gate/build tools
Start date:
2018-09-19
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:
Gerrit CR:

Description

ld(1) can provide guidance about things you probably should do while linking, which is actually based on our own best practices. We should enable this in our own build, and ensure we practice what we preach.

ld(1) can also ensure that libraries are not found on default search paths (ie, that illumos libraries are only found from the proto, adjunct libraries from an adjunct, etc.) We should enable this too, which prevents numerous otherwise hairy build races.


Related issues

Is duplicate of illumos gate - Feature #8411: Build should warn when linking against libraries outside proto areaClosed2017-06-19

Actions
Actions #1

Updated by Andrew Stormont about 3 years ago

  • Is duplicate of Feature #8411: Build should warn when linking against libraries outside proto area added
Actions #2

Updated by Toomas Soome over 1 year ago

  • Status changed from In Progress to Closed

Duplicate of 12217

Actions

Also available in: Atom PDF