Project

General

Profile

Actions

Feature #9878

closed

zio_free_sync() should recognize gang block size

Added by Toomas Soome over 2 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
zfs - Zettabyte File System
Start date:
2018-10-09
Due date:
% Done:

90%

Estimated time:
Difficulty:
Medium
Tags:
Gerrit CR:

Description

The zio_free_sync() in illumos tree does not recognize gang block size while freebsd does via passing extra size argument (http://src.illumos.org/source/xref/freebsd-head/sys/cddl/contrib/opensolaris/uts/common/fs/zfs/zio.c#997).

Using extra argument there seems like unneeded overhead, we can use BP_IS_GANG() to select between SPA_GANGBLOCKSIZE and BP_GET_PSIZE(bp) in zio_free_sync() and avoid introducing size argument.

Actions #1

Updated by Toomas Soome about 2 years ago

  • Tracker changed from Bug to Feature
  • Status changed from In Progress to Closed

Apparently not a bug. have not been able to confirm it.

Actions

Also available in: Atom PDF