Project

General

Profile

Actions

Bug #993

closed

Marvell SATA controller 88SE9128 - driver issue?

Added by Lou Picciano over 10 years ago. Updated over 8 years ago.

Status:
Closed
Priority:
Low
Assignee:
Category:
driver - device drivers
Start date:
2011-05-05
Due date:
2011-09-14
% Done:

0%

Estimated time:
10.00 h
Difficulty:
Medium
Tags:
SATA Controller
Gerrit CR:

Description

We are unable to configure any drive connected to the Marvell 88SE9128 controller. (controller is apparently implemented as a PCI device)
mobo: GigaByte GA-P67A-UD7-B3
Note: all drives controlled directly by the P67A work fine.

Specifically:
Drive does appear in cfgadm connected/unconfigured

  1. cfgadm c configure sata1/0
    --
    Failed to config device at ap_id: /devices/pci@0,0/pci8086,1c1c@1c,6/pci1458,b000@0:0

After making these changes to /etc/system:

set ahci:ahci_msi_enabled = 0
set sata:sata_max_queue_depth = 0x1

  1. cfgadm -a (does not even see the 'type' as sata-port):
    sata1/0 unknown connected unconfigured unknown

Related issues

Is duplicate of illumos gate - Bug #3815: AHCI: Support for Marvell 88SE9128ResolvedMarcel Telka2013-06-14

Actions
Actions

Also available in: Atom PDF