Project

General

Profile

Actions

Bug #9980

closed

Occasional unwanted autotools rebuild for gcc compilers

Added by Gary Mills about 4 years ago. Updated almost 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
OI-Userland
Target version:
Start date:
2018-11-14
Due date:
% Done:

0%

Estimated time:
1.00 h
Difficulty:
Bite-size
Tags:
needs-triage

Description

These error messages appear occasionally during build of any of the gcc compilers that copy additional source files into the main source archive:

configure.ac:35: error: version mismatch.  This is Automake 1.15,
configure.ac:35: but the definition used by this AM_INIT_AUTOMAKE
configure.ac:35: comes from Automake 1.15.1.  You should recreate
configure.ac:35: aclocal.m4 with aclocal and run automake again.
WARNING: 'automake-1.15' is probably too old.
         You should only need it if you modified 'Makefile.am' or
         'configure.ac' or m4 files included by 'configure.ac'.
         The 'automake' program is part of the GNU Automake package:
         <http://www.gnu.org/software/automake>
         It also requires GNU Autoconf, GNU m4 and Perl in order to run:
         <http://www.gnu.org/software/autoconf>
         <http://www.gnu.org/software/m4/>
         <http://www.perl.org/>
Makefile:404: recipe for target '/export/home/mills/Downloads/code/oi-userland/components/developer/gcc-7/gcc-7.3.0/mpfr/Makefile.in' failed

The cause is bad timestamps on files under control of the autotools. It happens because the copy commands in the top-level Makefile do not preserve timestamps. The solution is simply to change the copy options so that they do preserve the timestamps in the original source archive. I needed this change with gcc-7, but it likely applies to all of the OI gcc compilers:

< COMPONENT_POST_UNPACK_ACTION_1 += ( $(RM) -r $(COMPONENT_SRC)/$(MPFR_NAME) && $(CP) -r $(COMPONENT_SRC_1) $(COMPONENT_SRC)/$(MPFR_NAME) )
---
> COMPONENT_POST_UNPACK_ACTION_1 += ( $(RM) -r $(COMPONENT_SRC)/$(MPFR_NAME) && $(CP) -rp $(COMPONENT_SRC_1) $(COMPONENT_SRC)/$(MPFR_NAME) )
58c59
< COMPONENT_POST_UNPACK_ACTION_2 += ( $(RM) -r $(COMPONENT_SRC)/$(MPC_NAME) && $(CP) -r $(COMPONENT_SRC_2) $(COMPONENT_SRC)/$(MPC_NAME) )
---
> COMPONENT_POST_UNPACK_ACTION_2 += ( $(RM) -r $(COMPONENT_SRC)/$(MPC_NAME) && $(CP) -rp $(COMPONENT_SRC_2) $(COMPONENT_SRC)/$(MPC_NAME) )
66c67
< COMPONENT_POST_UNPACK_ACTION_3 += ( $(RM) -r $(COMPONENT_SRC)/$(GMP_NAME) && $(CP) -r $(COMPONENT_SRC_3) $(COMPONENT_SRC)/$(GMP_NAME) )
---
> COMPONENT_POST_UNPACK_ACTION_3 += ( $(RM) -r $(COMPONENT_SRC)/$(GMP_NAME) && $(CP) -rp $(COMPONENT_SRC_3) $(COMPONENT_SRC)/$(GMP_NAME) )
Actions #1

Updated by Alexander Pyhalov about 4 years ago

Will you create PR?

Actions #2

Updated by Gary Mills about 4 years ago

I'd be happy to leave the PR step to somebody else.

Actions #3

Updated by Alexander Pyhalov almost 4 years ago

  • Status changed from New to Resolved
Actions

Also available in: Atom PDF