Project

General

Profile

Bug #14164

Updated by Toomas Soome 3 months ago

We should use $TEST_BASE_DIR instead. 

 Testing done: zfstests result: 

 <pre> 
 tsoome@test:~$ env    DISKS="c3t1d0 c3t2d0 c3t3d0" /opt/zfs-tests/bin/zfstest -c /opt/zfs-tests/runfiles/removal.run 
 Test: /opt/zfs-tests/tests/functional/removal/removal_sanity (run as root) [00:02] [PASS] 
 Test: /opt/zfs-tests/tests/functional/removal/removal_all_vdev (run as root) [00:01] [PASS] 
 Test: /opt/zfs-tests/tests/functional/removal/removal_check_space (run as root) [00:07] [PASS] 
 Test: /opt/zfs-tests/tests/functional/removal/removal_condense_export (run as root) [00:40] [PASS] 
 Test: /opt/zfs-tests/tests/functional/removal/removal_multiple_indirection (run as root) [03:07] [PASS] 
 Test: /opt/zfs-tests/tests/functional/removal/removal_remap (run as root) [00:57] [PASS] 
 Test: /opt/zfs-tests/tests/functional/removal/removal_remap_deadlists (run as root) [00:14] [PASS] 
 Test: /opt/zfs-tests/tests/functional/removal/removal_with_add (run as root) [00:17] [PASS] 
 Test: /opt/zfs-tests/tests/functional/removal/removal_with_create_fs (run as root) [00:13] [PASS] 
 Test: /opt/zfs-tests/tests/functional/removal/removal_with_dedup (run as root) [00:01] [PASS] 
 Test: /opt/zfs-tests/tests/functional/removal/removal_with_export (run as root) [00:13] [PASS] 
 Test: /opt/zfs-tests/tests/functional/removal/removal_with_ganging (run as root) [00:04] [PASS] 
 Test: /opt/zfs-tests/tests/functional/removal/removal_with_remap (run as root) [00:13] [PASS] 
 Test: /opt/zfs-tests/tests/functional/removal/removal_with_remove (run as root) [00:14] [PASS] 
 Test: /opt/zfs-tests/tests/functional/removal/removal_with_scrub (run as root) [00:14] [PASS] 
 Test: /opt/zfs-tests/tests/functional/removal/removal_with_send (run as root) [00:16] [PASS] 
 Test: /opt/zfs-tests/tests/functional/removal/removal_with_send_recv (run as root) [00:37] [PASS] 
 Test: /opt/zfs-tests/tests/functional/removal/removal_with_snapshot (run as root) [00:12] [PASS] 
 Test: /opt/zfs-tests/tests/functional/removal/removal_with_write (run as root) [00:13] [PASS] 
 Test: /opt/zfs-tests/tests/functional/removal/removal_with_zdb (run as root) [00:16] [PASS] 
 Test: /opt/zfs-tests/tests/functional/removal/removal_resume_export (run as root) [00:10] [FAIL] 
 Test: /opt/zfs-tests/tests/functional/removal/remove_mirror (run as root) [00:02] [PASS] 
 Test: /opt/zfs-tests/tests/functional/removal/remove_mirror_sanity (run as root) [00:01] [PASS] 
 Test: /opt/zfs-tests/tests/functional/removal/remove_raidz (run as root) [00:01] [PASS] 
 Test: /opt/zfs-tests/tests/functional/removal/cleanup (run as root) [00:00] [PASS] 

 Results Summary 
 FAIL         1 
 PASS        24 

 Running Time:     00:08:35 
 Percent passed: 96.0% 
 Log directory:    /var/tmp/test_results/20211029T154356 
 </pre> 

 This one broken test seems to be related to something broken in my test system: 
 <pre> 
 mdb: unexpected kind for type ip_stat_t * (member spa_name of type spa_t) 
 mdb: unexpected kind for type ip_stat_t * (member spa_name of type spa_t) 
 cannot find device 'c3t1d0' in pool 'testpool' 
 </pre>

Back