Project

General

Profile

Activity

From 2017-06-27 to 2017-07-26

2017-07-26

01:25 PM Bug #8540 (Resolved): Remove legacy GNOME2 desktop apps
metacity*, baobab*
gnome-camera*, gnome-dictionary*, file-roller*
gedit*, evolution*, gcalctool*, gnome-terminal*,...
Ken Mays

2017-07-25

06:23 AM Bug #8532: Remove libglade
gnome-panel depends on notification daemon, so they should be removed simultaneously Alexander Pyhalov
06:09 AM Bug #8532 (New): Remove libglade
libglade is a deprecated Gnome 2 library. A set of non-gnome2 applications depend on it. We should fix these dependen... Alexander Pyhalov
06:03 AM Bug #8531 (New): Remove libgnomeui
libgnomeui is a deprecated Gnome 2 library. A set of non-gnome2 applications depend on it. We should fix these depend... Alexander Pyhalov
06:01 AM Bug #8530 (New): Remove gnome 2 libraries and applications
We still use several Gnome 2 libraries and applications. It's 2017. They should be removed.
This is a meta-issue to ...
Alexander Pyhalov

2017-07-24

11:56 AM Feature #8356: Current Seahorse 2.32 pkg based on code released September 2010
Also note that we likely will have to update gnome-keyring at the same time. Alexander Pyhalov
11:02 AM Feature #8356: Current Seahorse 2.32 pkg based on code released September 2010
For the record: pgp signature generation doesn't work in seahorse 3.20.0 (getting error 'Result too large'). It's wor... Alexander Pyhalov
09:19 AM Feature #8524 (Resolved): Bump MATE 1.18.x packages to recent versions
Fixed in https://github.com/OpenIndiana/oi-userland/pull/3360 Alexander Pyhalov

2017-07-23

06:18 AM Feature #8209 (In Progress): Install to a boot environment
GitHub PR: https://github.com/OpenIndiana/slim_source/pull/28
Test ISOs: http://buildzone.oi-build.r61.net/installer...
Alexander Pyhalov

2017-07-22

10:00 PM Feature #8524 (Resolved): Bump MATE 1.18.x packages to recent versions
Bump the following MATE 1.18.x packages:
mate-control-center-1.18.2.tar.xz
mate-media-1.18.1.tar.xz
mate-panel-1...
Ken Mays

2017-07-21

11:07 AM Bug #2931 (Resolved): PS1 prompt in default user .profile is incorrect
Resolved by referenced illumos ticket. Aurélien Larcher
11:04 AM Bug #7952 (Resolved): Sunray X server Xnewt crashs with package data-xkb@2.20
https://github.com/OpenIndiana/oi-userland/pull/2859 Aurélien Larcher
10:55 AM Feature #7108 (Resolved): Update Enlightenment to 0.21.7
https://github.com/OpenIndiana/oi-userland/pull/2977 Aurélien Larcher
10:54 AM Feature #7109 (Resolved): Update EFL to 1.18
https://github.com/OpenIndiana/oi-userland/pull/2976 Aurélien Larcher
10:52 AM Bug #7916 (Resolved): openexr required
https://github.com/OpenIndiana/oi-userland/pull/3117 Aurélien Larcher
10:41 AM Bug #8471 (Resolved): enlightenment: missing execute permissions on some files
My transforms in the manifest were not correct:
https://github.com/OpenIndiana/oi-userland/pull/3352
Aurélien Larcher
08:25 AM Feature #8467 (Closed): Provide GCC 7 as additional compiler

Aurélien Larcher

2017-07-19

08:48 PM Bug #8431: Firefox 52.2.0 certificate isues requiring cert8.db removal
The problem with the cert8.db file possibly relates to the size of the file or the order in which certificates are st... r a

2017-07-11

08:02 PM Feature #7609: Building ISC BIND 9.11.0-P1
I have built the latest version of Bind 9.11.1-P3 using the following command
CC=gcc CXX=g++ F77=gfortran FC=gfort...
r a
08:37 AM Feature #8483: Bump to libgphoto 2.5.x
I already have a branch with this update and others, I do not remember why I did not push it.
I can push it later an...
Aurélien Larcher
03:56 AM Feature #8483 (Resolved): Bump to libgphoto 2.5.x
Ref:
libgphoto2-2.5.14.tar.bz2
desktop/gphoto2
Brings gphoto-related packages to recent development and support....
Ken Mays

2017-07-10

10:09 PM Bug #8471: enlightenment: missing execute permissions on some files
Thank you for reporting!
I am travelling for now so I will not be able to fix it right away.
If you have time a...
Aurélien Larcher
09:05 PM Bug #8436: developer/gcc-49 installs incorrect os_defines.h
This is the default userland compiler. Aurélien Larcher

2017-07-08

10:06 PM Bug #8436: developer/gcc-49 installs incorrect os_defines.h
I just checked a few other gcc packages for OI Hipster. The erroneous lines only appear in the os_defines.h file for... Gary Mills
01:23 PM Bug #8431: Firefox 52.2.0 certificate isues requiring cert8.db removal
Just tried to connect using https and received a Secure Connection Failed error
See the attached error message
r a

2017-07-07

08:40 PM Bug #8471 (Resolved): enlightenment: missing execute permissions on some files
The files under _/usr/lib/amd64/enlightenment/utils/_ were installed with 0444 permissions on my machine, leaving thi... Andre Lupa

2017-07-06

07:35 PM Bug #8436: developer/gcc-49 installs incorrect os_defines.h
I guess it is up to you to check with illumos developers if it is reasonable then submit the changes.
At least I do ...
Aurélien Larcher
07:17 PM Feature #8467 (Feedback): Provide GCC 7 as additional compiler
Aurélien Larcher
06:04 PM Feature #8467: Provide GCC 7 as additional compiler
Ah OK :)
I should have them on my build server, otherwise I can re-run them.
You can see patches and test logs fo...
Aurélien Larcher
05:47 PM Feature #8467: Provide GCC 7 as additional compiler
Ticket can be removed per package: developer/gcc-7@7.1.0,5.11-2017.0.0.0:20170609T213424Z
Do we have build stats a...
Ken Mays
05:44 PM Feature #8467: Provide GCC 7 as additional compiler
What is the purpose of the ticket? Aurélien Larcher
05:35 PM Feature #8467: Provide GCC 7 as additional compiler
https://gcc.gnu.org/gcc-7/buildstat.html Ken Mays
05:33 PM Feature #8467 (Closed): Provide GCC 7 as additional compiler
Add GCC 7.x as additional compiler for FOSS compilation testing, packaging, and review.
Ref: https://gcc.gnu.org/g...
Ken Mays
05:57 PM Bug #8468 (New): Finnish listed twice in the installer's language selection
In the "Locale" phase of the graphical installer, a long list of languages is shown, and on that list Finnish is list... Lauri Nurmi

2017-07-05

02:50 AM Bug #8436: developer/gcc-49 installs incorrect os_defines.h
There is another copy of the same file at: i386-pc-solaris2.11/amd64/bits/os_defines.h . Both copies need the same c... Gary Mills

2017-07-02

10:13 AM Feature #7609: Building ISC BIND 9.11.0-P1
After upgrading to the latest release of Hipster I was able to successfully build and install BIND 9.11.2-P1
CC=gc...
r a
10:09 AM Feature #7465: Can the GeoIP v1.3.2 package in OpenIndiana Hipster be upgraded to v1.6.9
After upgrading to GeoIP 1.6.11 I was able to successfully build Bind 9.11.2-P1 with the following options
CC=gcc ...
r a

2017-07-01

03:01 PM Bug #8342 (Resolved): Insecure transport of OI cryptographic digests
Checksums were published on the 2017.04 release notes webpage.
Speaking of realistic attack scenarios, can you po...
Adam Števko
02:52 PM Feature #7465 (Resolved): Can the GeoIP v1.3.2 package in OpenIndiana Hipster be upgraded to v1.6.9
GeoIP upgraded to 1.6.11 Adam Števko
02:52 PM Feature #7609: Building ISC BIND 9.11.0-P1
geoip has been updated to 1.6.11. Adam Števko
02:51 PM Bug #8045 (Resolved): /hipster: geoiplookup does not return any data
geoip-database package with updated geoip ip provided. Adam Števko

2017-06-28

07:17 PM Bug #8436 (Feedback): developer/gcc-49 installs incorrect os_defines.h
The developer/gcc-49 package installs an incorrect version of /usr/gcc/4.9/include/c++/4.9.4/i386-pc-solaris2.11/bits... Gary Mills
 

Also available in: Atom