Project

General

Profile

Activity

From 2019-01-03 to 2019-02-01

2019-02-01

11:37 AM Bug #9977: Unable to boot from new BE since end of October 2018
Performed a "pkg refresh" , then a "pkg update -v --be-name 201902-01" which worked perfectly and it correctly inheri... r a

2019-01-30

03:07 PM Bug #10294: gcc-7 build fails with native assembler
I've confirmed that the same Makefile works on SPARC and x86. On x86 it does set HAVE_INITFINI_ARRAY_SUPPORT to 1.
...
Gary Mills

2019-01-26

10:43 PM Bug #10294: gcc-7 build fails with native assembler
Ah, the test in the gcc configure script doesn't work for illumos. You were right: you have to force it for illumos ... Gary Mills
02:42 PM Bug #10294: gcc-7 build fails with native assembler
This suggestion is not necessary for x86. If --enable-initfini-array is omitted, the gcc configure script still enab... Gary Mills
11:55 AM Bug #10294: gcc-7 build fails with native assembler
Linker support was added before I pushed gcc-7 so it is fine for x86.
If you make any change I suggest that you do n...
Aurélien Larcher

2019-01-25

11:54 PM Bug #10294 (New): gcc-7 build fails with native assembler
When the native assembler is specified, as it is for SPARC hardware, the build of gcc-7 fails with an internal compil... Gary Mills

2019-01-20

11:48 AM Bug #9977: Unable to boot from new BE since end of October 2018
Tried to boot kmdb with console=graphics, the system booted but all I had was a flashing _ in the upper left hand cor... r a

2019-01-19

04:35 PM Bug #9977: Unable to boot from new BE since end of October 2018
Great, so this is actually about @console=graphics@ option, unrelated to VirtualBox.
If you want to gather informa...
Michal Nowak
02:48 PM Bug #9977: Unable to boot from new BE since end of October 2018
As a hack to get the BE to boot without editing each time I modified the /rpool/boot/grub/menu.lst and removed the ",... r a
01:41 PM Bug #9977: Unable to boot from new BE since end of October 2018
Following the guidance in "How to Report Problems", I deleted the BE of the lastest update and booted into the Clone ... r a

2019-01-16

09:39 PM Bug #9977: Unable to boot from new BE since end of October 2018
Maybe "Gathering Information from a Running System" (https://wiki.illumos.org/display/illumos/How+To+Report+Problems)... Michal Nowak
08:25 PM Bug #9977: Unable to boot from new BE since end of October 2018
I made sure that VirtualBox was removed because I thought it was the cause of the problem.
The settings to generate...
r a
06:51 AM Bug #9977: Unable to boot from new BE since end of October 2018
If all VirtualBox kernel modules were removed, it ought to be a different crash.
Maybe some remnants of Oracle-shi...
Michal Nowak
06:43 AM Bug #10169 (Resolved): Can not Install GCC-8 on freshly patched 2018.10 Hipster
Michal Nowak

2019-01-14

01:42 AM Bug #10169: Can not Install GCC-8 on freshly patched 2018.10 Hipster
Appears to have fixed my issue. I tried a new install of the text ISO and it worked there after patching. I also patc... Jason Grove

2019-01-13

06:21 PM Bug #9977: Unable to boot from new BE since end of October 2018
I thought the same thing on Friday afternoon, so created a clone on my current BE, then booted from the cloned enviro... r a

2019-01-12

10:10 PM Bug #10228 (Resolved): GTK3 Color Selection cores application
The GTK2-like color selector in GTK3 causes application using this widget to core dump when using the dropper functio... Geoff Weiss

2019-01-11

07:56 PM Bug #10169: Can not Install GCC-8 on freshly patched 2018.10 Hipster
Should be fixed by following commits:
* https://github.com/OpenIndiana/pkg5/commit/86654b0040d31169695ea2d417b3fec32...
Michal Nowak
08:56 AM Bug #10169: Can not Install GCC-8 on freshly patched 2018.10 Hipster
The problem is being caused by the @text/gnu-grep@ package which contains this line in its manifest.
@license 3e7c...
Andy Fiddaman
08:29 AM Bug #10169: Can not Install GCC-8 on freshly patched 2018.10 Hipster
That's interesting. Turns out that my test system was building with oi-hipster-minimal, I'll re-test with -text. That... Andy Fiddaman
01:55 AM Bug #10169: Can not Install GCC-8 on freshly patched 2018.10 Hipster
I was able to replicate it in fresh install of openindiana-text tonight. Used the same procedure above, with this ISO... Jason Grove
07:23 PM Bug #9977: Unable to boot from new BE since end of October 2018
The trace looks to me similar to #9761, which was solved by porting VirtualBox to OI.
Remove VirtualBox provided b...
Michal Nowak
06:15 AM Bug #10156 (Resolved): /etc/ssh/sshd_config is outdated
https://github.com/OpenIndiana/oi-userland/pull/4681 merged.
Thanks for the report.
Michal Nowak
06:05 AM Feature #10172 (Resolved): Add zstd
https://github.com/OpenIndiana/oi-userland/pull/4706 merged. Michal Nowak
05:54 AM Feature #10181 (Resolved): Update vte-291 component to 0.54.3
https://github.com/OpenIndiana/oi-userland/pull/4701 merged. Michal Nowak

2019-01-10

06:27 PM Bug #10209 (New): Process gnome-keyring-daemon terminated by SIGSEGV on MATE start
After update of @gnome/gnome-keyring@ to @3.28.2-2018.0.0.0@, @gnome-keyring-daemon@ dumps core on every MATE start (... Michal Nowak
06:09 PM Feature #10180 (Closed): Add test target for bash-completion
Not worth it. Michal Nowak
03:49 PM Bug #10169: Can not Install GCC-8 on freshly patched 2018.10 Hipster
I can't replicate this in a freshly installed OpenIndiana-text
I will re-try with OI-hipster-gui
Andy Fiddaman
07:50 AM Feature #10192 (Resolved): Update git to 2.20.1
Fixed in https://github.com/OpenIndiana/oi-userland/pull/4705 Alexander Pyhalov
06:19 AM Bug #10203 (Closed): Can't install cvs and essential-build
Duplicate of #10169. Michal Nowak
02:07 AM Bug #10203: Can't install cvs and essential-build
(Some extra gibberish characters somehow got into the text file, mostly indicating hard returns. My apologies.) James Deagle
02:04 AM Bug #10203 (Closed): Can't install cvs and essential-build
I have been trying to install cvs and build-essential, but have not had any luck. The command "pkg install cvs build-... James Deagle

2019-01-09

07:12 AM Feature #10192 (Resolved): Update git to 2.20.1
Michal Nowak

2019-01-07

09:27 PM Bug #9705 (Closed): NTP client crashing
Now we have @service/network/ntp@4.2.8.12,5.11-2018.0.0.1:20190107T160118Z@, that should fix it for everyone. Let us ... Michal Nowak

2019-01-06

06:42 PM Bug #10169: Can not Install GCC-8 on freshly patched 2018.10 Hipster
Our automation tests noticed that too: https://openqa.oi.mnowak.cz/tests/4277#step/building_with_oi_userland/3. Michal Nowak
08:30 AM Feature #10181 (Resolved): Update vte-291 component to 0.54.3
http://ftp.acc.umu.se/pub/GNOME/sources/vte/0.54/ Michal Nowak
08:28 AM Feature #10180 (Closed): Add test target for bash-completion
https://github.com/scop/bash-completion/tree/master/test Michal Nowak

2019-01-05

04:16 PM Bug #9705: NTP client crashing
I'm happy with the changes in PR4695. The ntp service does not crash any more. The service is now stable, even afte... Geoff Weiss

2019-01-04

10:06 PM Bug #9977: Unable to boot from new BE since end of October 2018
After reading how to process the vmdump.0 file, I created the unix.0 and vmcore.0 files then processed them with
...
r a
09:54 PM Bug #9977: Unable to boot from new BE since end of October 2018
I used dumpadm to be configured as follows
# dumpadm
Dump content: kernel pages
Dump device: /dev/z...
r a
05:16 PM Bug #9705: NTP client crashing
Good point r a. We can disable the offending code by disabling debugging code via @--disable-debugging@.
Hence: ht...
Michal Nowak
03:34 PM Bug #9705: NTP client crashing
I looked at replacing the default ntp with ntp-4.2.8p12 and checking the logs for ntp and used
CC=gcc CFLAGS='-m64 ...
r a
07:14 AM Bug #9705: NTP client crashing
Thanks for the suggestion, Geoff.
Can you describe, what happens with the process (and service) after assertion fa...
Michal Nowak

2019-01-03

09:06 PM Bug #9705: NTP client crashing
I resynced my ntp build with userland, and was able to replicate ntp crashing after a few minutes. I don't have a so... Geoff Weiss
07:16 AM Feature #10172 (Resolved): Add zstd
zstd/Zstandard should be added to userland, GNU tar 1.31 supports it.
https://facebook.github.io/zstd/
https://gi...
Michal Nowak
 

Also available in: Atom